HELP -147 jtd- fuel filter changed, sometimes won`t start - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-02-10 Thread Starter
Status: Cq DX CT3-LG
AO Member
Time_Bandit's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: West Sussex
Posts: 39
HELP -147 jtd- fuel filter changed, sometimes won`t start

Hello to all. Please help me, i had check some threads but didn`t manage to resolve my problem. I had changed the fuel filter, not from Fiat but a OEM,re-used the same o-rings, the car had started ok, but since that sometimes he won`t start, i had to put the key to stop and to mar too many times, and for more than once, i had to disconect the fuel line after the filter, let some diesel run away and the he starts. When i disconet the fule line that goes to the high pressure pump i checked that the diesel inside disapears and makes a noise like vacum, the car war perfect just before changed the filter, may be from the o-rings?? Please help. Thanks


CT3-LG Madeira Island CQ DX
Time_Bandit is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2005
Location: North West of Ireland
Posts: 519
Images: 8
Go get a genuine filter. It will come with all the required o rings. Remove old filter, dispose of old o rings. Lubricate new rings with diesel, fill new filter with fresh diesel. Reassembly is reverse of removal. Your car should start on first turn of key.
Let me know how you get on.
Leitrim155 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , changed , filter , fuel , jtd , start , won`t

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome