147 2.0 ts Lusso 55..Suspension Squeeking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-02-10 Thread Starter
Status: -
AO Member
Join Date: Nov 2006
Location: United Kingdom
County: Surrey
Posts: 17
Images: 2
Help 147 2.0 ts Lusso 55..Suspension Squeeking

I have the 20ts on a 55 plate. 45.000 miles and i have a squeeking noise from the left side front and back. Im convinced its coming from inside the car but from what ive read on here could it be the suspension rubbers? Only does it on bumpy surfaces and not when cornering so im sure its not the wishbones or something like that. Steering feels fine. It does sound like something is dry and rubbing on something. Any suggestions on a cure and are the rubbers a sod of a job to do? Any help would be appreciated.
Russell B is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2009
Location: Macedonia, The Former Yug
County: -
Posts: 20

Member car:

156 2.0 ts

Its normal. Use search, theres so manu threads abouth it.
lawyer is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 55suspension , lusso , squeeking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome