VDC Fault? Check the connectors! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-02-10 Thread Starter
Status: GTV back to sleep again. 147 sele awakes!
AO Member
Blimpmiester's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Wiltshire
Posts: 241
VDC Fault? Check the connectors!

Owning my 156 thus far has been complete joy but it's had a small black cloud looming over the car since i bought two months ago. Every time i started the car the VDC/ABS warnig lights and beeping sounds would spring from the infocenter. Off to Smaky i went and he checked the ABS ecu connector which was covered in green corrision. Panicking at the idea that the ecu was shot and a new one came in at over 1k i thought i would have to sideline the car for a new months. Luckily the corrision seemed to be confined to just the plastic housing so once it was cleared off Smaky tried to clear the logged codes. Still no joy. Knowing that there are two vdc sensors on the steering colum he whipped the bottom trim off and there was the Vdc plug just dangling in thin air! One click of the plug into the connector and a ecu reset later and the car is back on form once again. Difficult to know why the plug should have "fallen" off as it's a nice secure fit. Unless it may have been tampered with in the past but just goes to prove that sometimes the simplest things can be over looked when dealing with our cars sometimes wayward electrics.
Thought i would share this small tale of joy with you all with VDC woes. Thanks again to Smaky for sorting my bella out.
Blimpmiester is offline  
Sponsored Links
Status: Looking for Add ons
AO Member
Sharpshooter's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Kent
Posts: 578
Images: 5

Member car:

Alfa Romeo 147

That was exactly the same thing as went wrong on my 147.
Sharpshooter is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

check , connectors , fault , vdc

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome