whisps of steam - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 16-02-10 Thread Starter
Status: going forward in reverse
AO Member
harpersimon's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Lancashire
Posts: 359
whisps of steam

When I am in standing traffic I occasionally notice whisps of steam coming out of the bonnet..
the temp is fine, coolant hasn't moved level wise, and although I know I need a thermostat one day as my car reads low like many others.. was wondering what it could be!?
I did think I was close to the cars in front sometimes and their exhaust was being blown into my grill then coming out when creeping forward, but its not that.
Does water drip onto something hot in the rain? any one any ideas?
harpersimon is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

could be coming out your own tail pipe and under your car thus impression of
davealfa11 is offline  
Status: .
AO Silver Member
Rob3rto's Avatar
Join Date: Sep 2004
Location: I would rather not say
County: -
Posts: 2,519
Images: 6

Member car:


When up to temp, on a cold and wet day, I get steam coming off my bonnet. If it is coming from inside bay, check back of rad, might have a tiny leak.
Rob3rto is offline  
(Post Link) post #4 of 8 Old 16-02-10 Thread Starter
Status: going forward in reverse
AO Member
harpersimon's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Lancashire
Posts: 359
thanks. last time i noted it when parking up, I left it running and immediately looked under the bonnet.. nothing! seems to come and go. Need to look for it on a dry day.. when we get one .. to establish if its my own coolant related. weird. if it was I'd expect it to do it all the time..
harpersimon is offline  
Status: Daddy bear
Global Mod Team
bazza's Avatar
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 42,041
Images: 3

Member car:

Alfa 156 GTA SW

I've had a panic about this in the past, only to realise it was rain on my hot bonnet evaporating. If you can't see anything wrong, and it's only happening when it's wet, I think you have nothing to worry about.
bazza is offline  
Status: - Update
Posts: n/a
has he got an undertray fitted? water could have saturated the bottom of the engine and its just drying out!
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Atmospheric condensate from the engine bay maybe? CI engines don't heat the bay as much as SI engines do, but get the thermostat sorted and check again?:
zulu ferret is offline  
Status: -
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: Essex
Posts: 339
when you noticed it on parking up - had you reversed into the space.... and over your exhaust trail, perhaps

I had a panic when sitting in traffic witha snow covered bonnet, temp rose to 90 as per usual, then steam blowing out the front of the car, hmm snow melting perhaps. Then traffic moved, and guage dropped to 60-70 rapidly, oh no, out of water?!? but no, that was the stat being dud, and the steam was just the snow. Get it sometimes with rain too, so hopefully nothing major to worry about so long as you're not losing coolant

djlat is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

steam , whisps

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome