Blowing fuse 156 JTD Sportwagon 03 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-02-10 Thread Starter
Status: -
AO Member
lylestv's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: East Sussex
Posts: 44

Member car:


Blowing fuse 156 JTD Sportwagon 03

Hi All,

I have had this problem ever since owning the car (a year now) its not the end of the world but figure it should be fixed. The fuse that controls the reverse lights, ASR and stereo keeps blowing, it blows within seconds of fitting. I assumed it was the aftermarket reverse sensors that have been fitted so checked the entire install, I even disconnected it entirely but still no joy. Has anyone else had this issue and can anyone point me to a possible solution?

Many thanks

lylestv is offline  
Sponsored Links
Status: On a Mission.
AO Member
Join Date: Dec 2009
Location: United Kingdom
County: Buckinghamshire
Posts: 825
If the fuse blows even when it's not actually in reverse, try disconnecting the reverse switch. If it still blows, the problem is likely to be elsewhere. Is the stereo the original factory fit one? If not, it may be wired incorrectly (even if it's the original, it's probably worth taking it out and checking for pinched/damaged wiring). Is there a phone kit fitted (or any sign that there has been)? These are normally connected to the stereo wiring.
FoxtrotOscar is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , blowing , fuse , jtd , sportwagon

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome