Possible window motors going? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-02-10 Thread Starter
Status: PS3 ID:HeavyweightHouse
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: West Midlands
Posts: 11

Member car:

147 1.6 TS Lusso

Possible window motors going?

So I was sat waiting for the missus to have her hair done and opened the drivers window in my 147, it went down no problems, then when i went to put it back up it really struggled, so I thought hmm maybe the motors on its way out? as the battery is healthy and fine and all other electrics are (at the moment) running without a hitch. But then I opened the passenger window to talk to someone i knew and again the same thing happened, which made me think it was a bit strange that BOTH window motors would be on the way out at the same time?

I don't know, I'm only 18 and this is my first Alfa so i'm not exactly seasoned in them as of yet but I can tell something is playing up...

any ideas??

Housey147 is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Was the engine running at the time? If not, they'll be slower than when it is...
iainfm is offline  
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Somerset
Posts: 150

Member car:

147 Selespeed

They can slow down due to a build up of muck in the window channels. Clean them out with a cotton bud and give them a good squirt of silicon spray grease.
Monkey Dust is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

motors , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome