Water Temp at Tickover in the cold weather - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-02-10 Thread Starter
Status: waiting to be flamed
AO Member
Join Date: Apr 2008
County: -
Posts: 178

Member car:

BMW 325i SE E92

Water Temp at Tickover in the cold weather

Hi, hope you can help with this strange one.

GT 1.9JTD 2005 which runs perfectly. Engine gets up to temp, sits bang on the centre line but in the very cold weather while idling in a traffic jam the needle drops to quarter way.

Now i thought it might go up a bit but i can't understand why the temp drops. The fan cut's in and out as i think it should and as i say car runs fine. Once i leave the traffic jam temp gauge returns to normal.

I wondered thermostat but again why would the temp drop?

Any thoughts gratefully received.


davek9 is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

to check therm
from cold warm engine up and feel top hose if it warms up as engine warms new stat needed
davealfa11 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cold , temp , tickover , water , weather

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome