156 2l ts injector light and airbag light on - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-02-10 Thread Starter
Status: In Bedford
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: South Yorkshire
Posts: 70

Member car:

156 2.0 TS

Help 156 2l ts injector light and airbag light on

Hello all I wonder if anyone can help, I'm a newbie here, I bought a V plate 156 with the cam belt snapped (on a whim silly me) I have repaired the head and fitted new belts tensioners etc. with a lot of help from this forum. I have got the car running eventually and it was ok for a few hours but then the injector light and the airbag light and a bulb fault light all came on together. Can anyone give me advice on what they could mean please I live near Bedford during the week and Doncaster at the weekend.

Thanks Glenn

wa068409 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , airbag , injector , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome