Squeeling Aux belt - I'm brassed off - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: #keepFightingMichael
AO Gold Member
EauRouge's Avatar
Join Date: Jun 2009
Location: Suriname
County: Brokopondo
Posts: 7,568
Images: 12
Jeronimo, can i ask!? Are/where you missing your lower belt cover?
EauRouge is offline  
Sponsored Links
(Post Link) post #27 of 28 Old 11-02-10 Thread Starter
Status: -
AO Member
Jeronimo's Avatar
Join Date: Feb 2006
Location: Gretton, Northants
Posts: 111
Images: 9
Originally Posted by EauRouge View Post
Jeronimo, can i ask!? Are/where you missing your lower belt cover?
No, full under-tray and inner wing covers were in place when I trundled along that track but I must have splashed mucky water over the aux belt.

Will take more care in future as I often go along there to fly my r/c slope soaring gliders
Jeronimo is offline  
Status: - Update
Posts: n/a
consider yourself lucky really, if the belt breaks its not impossible for it to get jammed into the cam-belt area , with the obvious outcome

glad it is all quiet again though, and without much cost

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

aux , belt , brasse , brassed , squeeling

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome