Selespeed works when off, But not when the engine is on - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 01-02-10 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Posts: 14

Member car:

156 selespeed

Selespeed works when off, But not when the engine is on

Hi, my Selespeed goes into gear all the time when you change with the engine off. But as soon as you turn the engine on it selects gears when it wants to. Is there a reason for this?


georgeb2008 is offline  
Sponsored Links
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
sele light on?

do you mean it goes into CITY mode when you say it changes gear when it wants to?
purple145 is offline  
Status: -
AO Member
Join Date: Jan 2008
Location: United Kingdom
County: Northamptonshire
Posts: 224
I'd be inclined to say your clutch rod needs adjusting or worse that you have a worn clutch. What mileage is the car on?
ChrisSound is offline  
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
I think you need to be a little bit more elaborate with your description of what's happening...

What happens when you change gear with the engine running?

Do you mean whilst in motion or engaging 1st/reverse from a standstill?

Any fault light on the dash?

Which gears are affected?

Selespeeds will drop down gears automatically even when in 'manual' mode (for example when stopping at a junction), so this is normal.
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , selespeed , works

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome