Buying 2003 Alfa 147 Selespeed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 31-01-10 Thread Starter
Status: -
Join Date: Jan 2010
Location: Australia
County: Australian Capital Territory
Posts: 5

Member car:

2003 Alfa 147

Buying 2003 Alfa 147 Selespeed

Hi everyone,

I am looking to buy a 2003 Alfa 147 Selespeed and wanted to check a couple of things before i commit.

its a 2003, with 72,000kms (in Australia). It had the Selespeed actuator replaced about 6 months ago, and had the timing belts etc changed on the last service a couple of thousand km's ago. so it should be fine right?

on the test drive i noticed 2 things

1 - a constant squeak from the front right. the owner mentioned he had been told it was the swaybar D bushes needing replacement. i contacted the service centre he uses for a vehicle history and they mentioned the same thing. in conjunction with this, i noticed the front right tyre was more worn than the front left, though the owner though they had been rotated at servicing. i have read a lot about the front wishbones, and am concerned it may be that.

2 - there was a 'slight' shudder when taking off from a standing start. it was ever so slight, and didn't happen every time. is this normal?, remembering the selespeed actuators were replaced recently?

Any advice, ideas on things to check?

is there anyone in Aus who can confirm an approximate cost for the wishbones if that is the issue with the front?

Thanks in advance for your help.

goforitifudare is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 2003 , alfa , buying , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome