Alfa 156 JTS trembling at low rev - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-01-10 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Posts: 16
Alfa 156 JTS trembling at low rev

Hi all,

I have a slight problem. Whenever I rev my car (let's say above 2-3krpm) and then take my foot off the accelerator pedal, the revs stop at around 1200 for 1-2 secs then the car trembles and then it goes down to normal 900-1000. What could trigger this? There is no problem when I go up in revs, only when it goes down.

I also need to mention that I do get the usual Motor control system failure from time to time in the morning when temperatures go below 0 degrees C (the lower the temp the longer it beeps). It usually beeps for 10 secs.

Also the diagnostics dude at the dealer told me that I get an error on cylinder 3 so I changed the plugs. Haven't been there since.

Any ideas? I'm thinking battery (after reading tons of posts). Gonna have it checked tomorrow. Thanks.
raduq is offline  
Sponsored Links
Status: faclifting a 156
AO Silver Member
biffa's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Images: 9
might be a coil pack on cylinder 3 or a failing lambda sensor (or crappy connection to lambda precat ones)
biffa is offline  
(Post Link) post #3 of 3 Old 30-01-10 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Posts: 16
I donno much about engine stuff but it would make sense that the coil would also make it jerk when it goes up in revs. Lambda sensor... could be. Should worry much about it? I mean the car goes like stink. I easily go to 200 with it. Actually did 230 so...
raduq is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , jts , low , rev , trembling

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome