Squeaking suspension - Page 3 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: OEM++
AO Silver Member
Egon's Avatar
Join Date: Jan 2012
Location: United Kingdom
County: Kent
Posts: 2,008

Member car:

147ts plus bits

I squeak. I have poly bushes all round on the front. even the ARB is poly. It still squeaks like an old morris marina. I used half a tub of copperslip putting the bushes in, greased everything else with high temperature grease and 3 months later its doing it again. I'm getting fed up with stupid little things that annoy me on the car now.
I agree that a grease nipple would be great, but getting it into the bush/sleeve interface may be tricky. I even devised a greased sleeve for the godforsaken bolt on the rear suspension that needs persuading with a sledge hammer.
Bloody italian cars.
Egon is offline  
Sponsored Links
Status: -
Join Date: Nov 2014
Location: Ireland
County: Clare
Posts: 0

Member car:


TUT squeeks 147

my 147 squeeks front and back.only 55000mls and its passed 2 national tests.irish MOT.it only does about 3000 per yr.must look at it soon.spraying sounds good
tony tierney is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

squeaking , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome