Clutch problem on 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-01-10 Thread Starter
Status: -
Join Date: Oct 2006
Posts: 4
Clutch problem on 147

Hi, I've just returned from a year abroad during which I left my 147 in storage with the clutch pedal wedged down (on the advice of a mechanic). I started it up today and found the pedal feels very loose at the bottom of pedal travel, and the biting point has moved right up to the top, with some slippage. The is no obvious leak of hydraulic fluid anywhere. Does this sound terminal ??!!
jpgolding is offline  
Sponsored Links
Status: squeeky suspension
AO Member
clubber's Avatar
Join Date: Oct 2009
Location: Bosnia and Herzegovina
County: -
Posts: 735

Member car:

A thirsty 147

Im not an expert, but it seems really weird to advise you to leave the clutch wedged down for a whole year. It could be the clutch cable became loose. You should try adjusting it. Hope it helps.
clubber is offline  
Status: -
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: -
Posts: 1,171

Member car:

147 JTDM 16V

No clutch cable on 147's, they are hydraulic.

I guess leaving it with the pedal wedged down stops the friction plate sticking to the other bits. Can't imagine this does the pressure plate any favors though. Almost sounds like the spring fingers have lost some of their strength, if that's possible. I guess it's a case of seeing if it improves with use, could just be rust on the friction faces.
Alexie is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , clutch , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome