147 rear windscreen Thud-fest. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-01-10 Thread Starter
Status: -
AO Member
Join Date: Oct 2009
Location: United Kingdom
County: -
Posts: 11

Member car:


Cry Like A Baby 147 rear windscreen Thud-fest.

As soon as I drive my 1.6 Lusso red 147 over anything but the smoothest surface there is an irritating bumping coming from the rear. I thought it was either something badly stowed in the boot or perhaps the luggage rack. However, I now realise, having noticed when washing the car, that it is the rear window. If you press on the lower left corner of the rear windscreen then you can hear how it would thud thud as you go over a bump.

Anyone else get this? Flipping annoying so a handy fix would be welcome.

Gesmi is offline  
Sponsored Links
Status: -
AO Member
dick dastardly's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Hampshire
Posts: 170
Images: 2

Member car:


Had a similar problem with my 147 a couple of years ago. It was caused by the hatch not shutting properly. Sorted by adjusting the boot catch (sometimes gets loose or knocked) and giving a couple of turns on the bump stops.
Needed to do the same on my GT recently, must be an Alfa thing! Hope it helps.
dick dastardly is offline  
Status: - Update
Posts: n/a
Missing rubber stop?

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , rear , thudfest , windscreen

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome