radio - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-01-10 Thread Starter
Status: -
Join Date: Jan 2010
Location: United Kingdom
County: Herefordshire
Posts: 7
Boxing radio

hi folks i have a 147 alfa and the radio is being a bit of a pain some times i start it up no sound the radio and sat nav all start up but no sound .if i switch it on and of a few times and take key out more often or not i get sound can any one help cheers mark w
mark williams is offline  
Sponsored Links
Status: bought a 75 3.0
AO Silver Member
155 Lounge Winner 09
shiny_car's Avatar
Join Date: Dec 2006
Location: Australia
County: Victoria
Posts: 7,669
Images: 39

Member car:

GT . 155 . 75

most likely a faulty headunit, rather than faulty power supply (like bad wiring, low voltage, fuses).

if you are inclined to check things, then remove the headunit, and check the voltages from the main powerwires (eg: UB+ wire).

i presume the wiring has never been altered by you or a previous owner who may have fitted an aftermarket headunit.

shiny_car is offline  
Status: -
AO Member
alfa-mick's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: South Yorkshire
Posts: 405

Member car:

147 1.6 lusso

it could be a loose speaker plug on the back of the unit. best thing to do is remove the unit make sure everything is plugged in securley. if it is then i would suspect a faulty unit.
alfa-mick is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome