jtd glowplugs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
jtd glowplugs

During the recent cold spell, my car took some serious turning over before it would start. So I looked into it a bit further and I found that disconnecting a glow plug reported an error on the dash. So assuming everything is okay, as I get no errors when I don't intervene how long do you guys leave the ignition on before attempting to start? To my surprise there are some very small cables to each glow plug, maybe 1.5mm at best? My older cars had huge connections to relays with 6mm wires and they always started after 2 seconds at worst? Anyone's thought would be appreciated!
Sponsored Links
Status: - Update
Posts: n/a
the common rail diesels don't rely so much on glow plugs as the older mechanical injection cars do. unless it gets very cold they aren't really needed that much. on all my jtd's (fiats & alfas) i never waited at all, started straight away.
of course there is no heam in changing them...........as long as they come out ok. i've heard stories of the threads being stripped when taking them out, or worse still breaking off

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

glowplugs , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome