Any ideas on what these probs could be? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 21-01-10 Thread Starter
Status: -
AO Member
Felty's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Warwickshire
Posts: 181
Any ideas on what these probs could be?

I'm hoping my nightmare 147 is settling down and not going to give me too much trouble until I sell up at the end of the year. Surely the law of averages applies to Alfa ownership too!?

First prob I have is that when accelerating moderately (1.9MJET) I can hear a kind of scraping/hissing noise coming from the front...could be engine maybe something else. Any ideas?

Also, does anyone else have a problem with severe pulling to one side (in my case the right, unusual) on the motorway. If I let go of the steering wheel it almost immidiately changes lane to the right!? I've got new tyres all round, had the tracking checked, taken it to a 4 wheel alignment specialist and made sure the pressures are good. Any ideas would be welcome.

It's going in for a service to my local independent soon so It'll be good to get some ideas to put across to them.

The car was badly vandalised the other day. Some lovely person keyed 2 massive scratches on the bonnet and then one on each of the passenger side doors (4 in total). They also jumped up and down on the bonnet (saw shoe footprints etc) and put a few nice dents in there too. Minimum quote so far (Bodyshop) is 500 without dents fixed.

Happy days

Had the car for 1 year and just to update here's the story so far from my massively edited blog which I'm eventually sending to Alfa Head office:

Bought car..then idiot dealers delayed pick-up with body computer fault.

Idiot dealer took 8 months to send me V5 ownership documents.

Changed dealer to competent local one.

Windscreen wiper drivers side broke. Sorted by dealer.

Clutch pin broke...stranded on M40. Replaced by dealer under warranty now very notchy and squeaky but really can't be bothered any more.

Clutch became extremely heavy and stiff. Took to dealer and they said there was nothing wrong.

Then the clutch went (or percieved as on it's way out). Replaced by dealer under warranty.

Severe internal water leak in passenger side footwell. Allegedly sorted by dealer under warranty.

Leak problem came back. Allegedly sorted by dealer under warranty.

Leak problem came back again. Sorted by dealer under warranty with replacement carpets all round.

Car started to shake and judder on motorway. Took to dealers to be checked and they said there was nothing wrong.

Car started to judder severly on the motorway. Took it back to dealers and after inspection a section of the drive shaft mechanism had broken. Replaced under warranty by dealer but took a whole week to sort.

Brakes froze on during the big freeze in Jan. Car wouldn't drive forward and when it did caused massive burning smell from jammed on brakes. Took to dealer...Cables were found to have been frozen and replaced under warranty. Charged me for 1 replacement brake caliper.

Got car back and still heavy clutch, hissing noise and pulling severly to the right.

....and you know what. I still love this car!!!!???? Call me an idiot but I can't help but appreciate the way it feels to drive and the way it looks.

BUT NEVER AGAIN!!!!!!!!!!!!!!!!!!!!

New Giullietta looks bl**dy nice though!

sʞɔoɹ ɹǝʇxǝp
Felty is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2009
Location: United Kingdom
County: Berkshire
Posts: 33

Member car:


don't use a body shop for sratch repairs use a mobile. less overheads= less cost to punter!!
biggus1984 is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
With pulling it could be break disc binding which may also describe the scraping noise. Other possibles would include upper and lower wishbones on the way out which would make it a bit unstable.
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

ideas , probs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome