147 2.0 TS 2002 CD/SATNAV problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-01-10 Thread Starter
Status: -
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: Greater London
Posts: 10
Hmmm 147 2.0 TS 2002 CD/SATNAV problem

Hi Members/Experts/Alfafiles, Just bought my first Alfa and am having a problem with the integrated CD/Sat Nav. Takes a few attempts to put the CD in after which it accepts. Then get NOCDA sign. The SATNAV works intermittently as does the music CD but skips music even when not driving. Your advice on assitance would be much appreciated.
mezool is offline  
Sponsored Links
Status: Missing some horses somewhere :(
AO Member
chillihound's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Greater London
Posts: 953
I understand your frustration but I don't think repeatedly posting new threads on the exact same subjet is going to increase your reponses, there are 2 threads in the 147, 156 & GT forum plus one in the ICE forum which incidently is the right place for a request of this nature.

I wish I could help you but my SatNav Connect + has worked without the issues you describe.

Be Patient.
chillihound is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 2002 , cd or satnav , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome