Ait filter woes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Ait filter woes

I've finally reached a stage where I have to change my air filter and I've got a bolt problem. One came out fine but the other two are turning without coming out.

I'm guessing there's a metal insert in the housing that's come loose. Is there any way of dealing with it other than just lopping off the bolts with my grinder?

I plan to remove the box to sort it, do I need to remove anything other than the top hose in order to extract it?

n.b. the resonator box is long gone in favour of a V6 intake so I only need to pull that from underneath.
Sponsored Links
Status: - Update
Posts: n/a
If you get the lid off maybe you can separate the inserts from the bolts and then you could araldite the inserts back in the airbox body, when i did mine the heads were fooked so i had to cut them off, then i cut the heads of some 6mm bolts and araldited them in the holes where the inserts came out of and used nuts to secure the lid all niceley greased up to avoid further trouble

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

ait , filter , woes

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome