Selespeed @ 170 bar pressure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 14-01-10 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Posts: 14

Member car:

156 selespeed

Selespeed @ 170 bar pressure

Hi, i have a 156 selespeed and this is the last resort to fix it. It is currently fluctuating at pressure of upto 170 bar, With the scanner plugged in the pressure will go upo and down from 70 to 170 but without the pump actually coming on. I have fitted a new accumulator but with no results. It will select gears occasionally but will crunch into them or get stuck in them.

can anyone shed any light upon this problem please . . a blockage maybe?

thanks george
georgeb2008 is offline  
Sponsored Links
Status: Bavarian
Admin Team
bobda's Avatar
Join Date: Jul 2002
County: -
Posts: 15,247
Images: 13

Member car:

Not a GT

How can the pressure change so much without anything happening?
Guessing here (someone more experienced will hopefully comment) but it sounds like a dodgy sensor.
bobda is offline  
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
The pressure can't go up if the pump isn't running. It should prime to 50bar, then drop to 45 or so as the gears are selected, then re-charge to 50-55bar.

Sounds like the pressure sensor is knackered or the connector is dirty. It's the wire at the bottom/right of the actuator.

I've arrowed it on this picture ->
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

170 , bar , pressure , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome