Steering problem after changing the power steering pump. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-01-10 Thread Starter
Status: -
AO Member
Join Date: Aug 2009
Location: Poland
County: Dolnoslaskie
Posts: 20
Steering problem after changing the power steering pump.

- I had a problem with steering in alfa, namely, it it didn;t stop working, just the contrary, it worked with greater force. Just touching the steering wheel casused the wheels to turn fast. Besides there was a strange sound that could be heard just behind the steering wheel. Sth like bubbles running through a pipe with high pressure.

- I have just got my power steering pump changed. Now turning is better but still not as it used to be. It turns a little bit too quick. I can't get used to that. As if I was playing a game with a steering wheel and at the same time didn't have enough control over the car.

- The pumps' changed but the sound remained. It only occurs while turning the steering wheel as if there was sparkling water running through a pipe just behind the steering wheel or the speedometer.

- Can it be a rotary valve? If there is such a thing in alfa, of course. Its purpose is to assist the driver only when he is exerting force on the steering wheel (such as when starting a turn). When the driver is not exerting force (such as when driving in a straight line), the system shouldn't provide any assist. But still don't know if alfa has got it...

- Or maybe it's a reconditioned rack?

Last edited by ideally; 12-01-10 at 15:02.
ideally is offline  
Sponsored Links
Status: -
AO Member
alid1's Avatar
Join Date: Mar 2006
Location: United Kingdom
County: West Midlands
Posts: 656
Images: 5

Member car:

Alfa 147 JTDm

You might have air in the system or air getting in-Open the fluid cap and check for bubbles. The fluid should be still but usually air in the system would result in the steering getting slightly stiffer but you never know
alid1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

changing , power , problem , pump , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome