156 Wipers - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-01-10 Thread Starter
Status: -
Join Date: Dec 2008
Location: United Kingdom
County: Hampshire
Posts: 6

Member car:

alfa romeo 156

156 Wipers

Hi All,

My wipers have packed up on my 156 53 plate. The fast wipe however has never worked since i brought the car.

I have checked all fuses and they seem fine. Is there a relay?? Or is this all controlled with the modual on the actual wiper motor?

I have started to take apart to see if i can get them going, but am struggling taking the cover off which surrounds the bottom of the windscreen. After removing the wiper arms and unscrewing about 5 fixings i still cant seemm to remove the cover.

Does anyone have any ideas or past experience of this???

Any help would be appreciated.

ptc41 is offline  
Sponsored Links
Status: -
AO Member
Simpatico's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Durham
Posts: 141

Member car:

147 Q2

The cover is just on friction clips, after taking the 5 screws out pull it UPWARDS. Refitting requires tapping it down with your hand but be careful, my screen cracked the day afterwards

My wipers did the same (no fast wipe either), never got to the bottom of it. I was told the motor was at fault but on taking it apart there didn't seem much wrong with it - wondered if it was the middle control box instead? There is a thread where someone had an auto electriciam re-solder a short there. IMHO the scuttle well is badly designed and collects too much damp to locate electrical components there.
Simpatico is offline  
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
If you've managed to get the twp phillips screws out at each end of the trim (Under circular plugs at the bottom of the screen pillars) and undone the tiny torx-head bolts along the front edge of the trim, then the trim does pull off as said......

156 and GTV wiper motors / mechanisms do seem to be relatively prone to failure....I've sold quite a lot of them.
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , wipers

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome