Really stoopid question time - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Really stoopid question time

Can this freezing weather bugger your water pump?

Reason I'm asking is last night at around 9pm with a temp of minus 5 I started the 147 and it made a terrible sound on start up. Hard to describe the sound but it abated after the engine warmed up (5 mins).

Same thing again this morning - same sound (temp of minus 10) and same thing again half an hour ago (minus 6).

Once car is running till engine is warm it is ok but before that it makes a terrible sound.

Sponsored Links
Status: Married
Regional Representative
For East Midlands - AOEM
braddersR's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Leicestershire
Posts: 42,019
Images: 13
If your coolant fluid has the right level of antifreeze in it should be ok i reckon.
braddersR is offline  
Status: - Update
Posts: n/a
I think antifreeze is normally good to -25C so as long as
you've got a proper mix it should be fine.

Don't top up with neat stuff as it's the 50:50 mix that is quite important.
Too much can cause overheating at the other end of the scale.
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
I am thinking it is more likely a tensioner for the aux belt, either the fixed or sprung one. Mine sounds nasty until it gets warmer, after a couple of mins, and on the 145 too. Getting replaced next week.
purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

question , stoopid , time

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome