Alfa 156 Selespeed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 07-01-10 Thread Starter
Status: -
AO Member
Join Date: Nov 2009
Location: United Kingdom
County: Warwickshire
Posts: 31
Crazed Alfa 156 Selespeed

I have been having erratic idle and thought the warning light was the airbag. I have turn airbag on and it still remains. Its a very dull light on the speedo that flashes contantly but to dull to make out. Its located next to the km/h '0' if that makes sense. Cant find a picture and/or description anywhere. Please help.
jon156 is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
I don't have one on me(!), but looking at picture on ebay, I *think* it's the brake warning. Handbrake/low oil/low material possibly?

I'll check one at home later and see if I can confirm or deny this!
iainfm is offline  
Status: skint!
AO Silver Member
cannotstop's Avatar
Join Date: Aug 2009
Location: Ireland
County: Dublin
Posts: 1,197

Member car:

156 GTA & 156 Ti

On a pre-face lift there are three lights near the 0 in the speedo.
They are: passenger airbag, brake and seatbelt.

The brake light is a circle.
cannotstop is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome