2002 Alfa 156 Speaker Replacement?? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #26 of 31 Old 08-01-10 Thread Starter
Status: Chillin
AO Silver Member
Chocoboy's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621
Images: 13

Member car:

2005 147 JTD

probably a daft question i know, but are there any other Head units that will also allow the controls on the steering wheel to work
Chocoboy is offline  
Sponsored Links
Status: -
AO Silver Member
Photodave's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: Derbyshire
Posts: 2,012

Most of the big names (Pioneer, Alpine, Kenwood etc) can be linked to the steering controls via an adapter.

Go on a site such as Car Audio Direct and you can look up all the gubbins. Usually about 40-50 quid to sort out, mind. Done it with mine (Pioneer DEH-P65BT) and it works perfectly
Photodave is offline  
Status: -
AO Member
Join Date: Apr 2009
Location: United Kingdom
County: Dorset
Posts: 76

Member car:

156 SW 2.0 TS

What if your standard head unit controls the cd multi-changer in the boot? Do they make gubbins for that?
Jammyjim is offline  
Status: - Update
Posts: n/a
Originally Posted by danny140986 View Post
probably a daft question i know, but are there any other Head units that will also allow the controls on the steering wheel to work
As said above you can get adaptors to make a wide range of HU work however some of the Alpine HU will/should allow the steering controls to work without any adaptors
Status: -
AO Silver Member
Join Date: Aug 2005
Location: United Kingdom
County: Bristol
Posts: 1,556

Member car:

Alfa GT

I am sure this will bring a lot of giggles and I normally wouldn't advocate it, but I was utterly impressed by the sound quality after fitting some 6x9's I had sitting around into the back of my first 156. (Standard fitment on the 156).

The bass response picked up the entire car and brought it into total harmony. The speakers were Rockford Fosgate "Thump" if I remember rightly and they were about a million times better than any other 6x9 setup I had heard in my "youth". They are probably about 7 years old now, so the likely hood of finding them now is probably nigh on impossible, not sure how current 6x9's compare.

Blow's away the Bose setup in my current car, wish I had remembered to pull them out before I sold the car (out of sight...out of mind).

Current Italian Cars:-
2004 Alfa Romeo GT 2.0 JTS
Previous Italian Cars :-
2003 Maserati 4200 Cambiocorsa
2006 Alfa Brera 2.2 SV JTS
1999 Alfa Romeo 156 2.4 JTD
2005 Alfa Romeo 156 2.0 JTS Veloce
2004 Alfa Romeo GT 1.9 JTD
2001 Alfa Romeo GTV 3.0 V6 Lusso
2002 Alfa Romeo 156 2.0 JTS
V6Alfisti is offline  
Status: going forward in reverse
AO Member
harpersimon's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Lancashire
Posts: 359
all factory fitted ones - Kenwood head unit (slightly old one) and factory fitted Sub in the boot - sound is excellent IMHO. Always room for improvement but I am a radio 2 listener so I don't need to let the neighbours hear it.
Connectors - I had the same intermittent speaker problem and I think its the weak door connectors. Check the connector type though first - I posted on here before after some advice to 'twist the connector' was wrong for the type I have. On mine, a large Blue clip holds the connector together. Lever this up and the connecter splits apart. With this type if its twisted, it will break so I say again, check the connector type!!

Live Fast, Die Young (Leave a Good Looking Corpse)
harpersimon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2002 , alfa , replacement , speaker

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome