Clock Resetting/Possible Battery Issue? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 31-12-09 Thread Starter
Status: with tunes!
AO Member
Join Date: Jul 2008
Posts: 75
Clock Resetting/Possible Battery Issue?

My wife keeps reporting that when she gets in here car the clock has reset to 0:00 this has happened about 6 times recently and has even resulted in me having to give her a jump start from my ****ty old M reg golf on one occasion.

Could it be that the battery is on its way out or something else?

It has only had an issue starting on one occasion, so I am thinking perhaps it is a dodgy connection, which won't be that easy to find for a numpty like me especially with that jazzy connection thing on top of the battery.




Second Alfa - impulse purchase...not as practical as the estate I went out for
krhall is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , clock , issue , resetting or possible

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome