Alfa 156 2.0 Twin Spark temperature and injector probs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-12-09 Thread Starter
Status: -
Join Date: Dec 2009
Location: United Kingdom
County: Buckinghamshire
Posts: 1

Member car:


Alfa 156 2.0 Twin Spark temperature and injector probs

Hi all,
I was wondering if anyone might be able to help out with a problem I have on my alfa 156 2.0 TS. The temp gauge rarely goes over 50 C only when you are idling and then it goes just over. The fan also comes on intermitently at this temp even when the outside temp is less than zero! The injector warning light on the dash comes on regularly but does not stay on all the time maybe for 15 mins at a time. When the car starts it also runs very flat for the first few mins, and increasingly i am noticing a bit of hesitancy/power drop intermitently while driving normally this is not massively noticable at the mo tho. I realise there appear to be several problems here but I am hoping that they are all linked! My car has done 155k. I wonder whether it might be the lambda sensor? I think the car only just scraped through the emissions test also if this is any help!

Hope you can help.

JamesEd is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
You need a new thermostat.

Re the fan, it will do that if the A/C is on.
David C is offline  
Status: Just when you thought it was safe mwahaha ;)
AO Gold Member
Alfa-Red's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Lancashire
Posts: 6,811
Images: 8
^^ as above
Alfa-Red is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , injector , probs , spark , temperature , twin

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome