Driver heated seated not working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-12-09 Thread Starter
Status: back in the UK
AO Member
Join Date: Apr 2009
Location: United Kingdom
County: West Midlands
Posts: 22
Driver heated seated not working

Hey all

I've looked up this and read a few threads, but nothings 100% so thought I'd ask

The drivers seat wires, were pulled out and jammed, i managed to pull it out and lose a prong. I pulled some plastic back and carefully put the wire back in, and now the light for the seat comes back on. I'm assuming this is just a power feed for the switch

Anyway, I have a light on the side, the yellow light comes on fine when I turn it on, but no heat, nothing at all!

Is it something else? Is there sensors that trigger it to work? I remember in the summer a light use to flicker on/off warning if my seatbelt hadn't been fitted, but it suddenly stopped doing it, so i'm guessing it could be related

Thanks in advance

Last edited by andystyler; 21-12-09 at 19:17.
andystyler is offline  
Sponsored Links
Status: its a GTA
AO Member
powercut68's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Lancashire
Posts: 212

Member car:

147 jtd mjet

mine was the same it was a bad connection on the outer 2 pins (centre 2 is for the light). would come on by applying pressure to the plug on the switch. i fixed it by bypassing the the plug connection by using male and female plugs from a model shop (high current ones). soldered male plug to the switch and female plug to the actual socket pins that you can see. all works fine now and you can still unplug it all.
powercut68 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

driver , heated , seated , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome