Heater blowers - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-12-09 Thread Starter
Status: -
Join Date: Sep 2009
Location: United Kingdom
County: Essex
Posts: 1

Member car:

156 sportwagen

Hmmm Heater blowers

Hi all
I have a 2001(Y) 156 Sportwagon 1.8.
I usually leave the Heater /Climate Control on :-
Left Dial - 24 or 21
Middle Dial - Auto
Right Dial - Max (move to interior blowers when screens clear)
and this has always been just fine & dandy for me until yesterday when the blowers refused to come on, when I checked the outside temp display its showing -16 ( it's varied from -13 to -20), but always worked correctly previously. I've tried changing all the controls but I cannot get the blowers to work at all, which is a bit of a bind in the current conditions especially as I work shifts & have to leave home at 0330 this week.
Any ideas?

Last edited by lesnorton; 21-12-09 at 17:48.
lesnorton is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Possibly the blower control module that's mounted next to the blower behind the glove box. The blower usually works at some setting (but not all) when it goes though...
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

blowers , heater

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome