still wont start any checks i should make ? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-12-09 Thread Starter
Status: -
Join Date: Oct 2008
Location: United Kingdom
County: Derbyshire
Posts: 4
Help still wont start any checks i should make ?

Hello again

alfa 156 1.9 jtd 16v - problems - last friday started fine left it running to defrost , ran for 10 mins then stopped, left it 5 mins ran for 20 secs then stopped again. It had 14 litres of fuel but i have a very steep sloping drive, so i wondered if i'd run out of diesel, on investigation not much diesel around either at the diesel filter or injectors, put another 15 litres of fuel in , changed the fuel filter ( looked ok in the old one ) . Now seem to have diesel at the injectors & at the fuel filter, turns over but still wont fire, I'm open to any suggestions, fed up with walking in this weather

Merry xmas to everyone - hopefully it's going to run before then !
wainey69 is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Injectors could be blocked?
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

checks , make , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome