Under-engine cover, is it needed? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: drifter
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: West Sussex
Posts: 1,067
Hi, Ive always considered them a good idea as on the odd occaision driving down the motorway with stretches of flood water it must help avoid the spray splashing up against the alternator which is in a low position or other electrical parts and wiring etc.Im of the opinion manufacturers do everything in their power to minimise production costs so they fitted this part for a reason.
seymour beaver is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2009
Location: United Kingdom
County: West Lothian
Posts: 82
Originally Posted by XJR40 View Post
Thanks for the replies.

One thing I would say is that none of the other cars I have owned have ever had such a cover, it seems like a relatively new innovation. There's nothing fundamentally different about the 156 to any other car as far as I can tell and others've not been adversely affected but not having such a cover.

My 92 SVX has one on, and the engine bay looks as new the day it hit the roads.

Bought one off ebay from Poland, new for 15.00 and quite sturdy plastic, wouldn't be without it with the ****e we get on British roads in the winter......and summer

No advantage leaving it off

blueji is offline  
Status: Occasionally driving my Gtv
Club Member
Membro Medio
alexGS's Avatar
Club Member Number: 1265
Join Date: Jul 2007
Location: New Zealand
County: Waikato
Posts: 2,361
Images: 36

Member car:

Gtv V6

Originally Posted by symon View Post
Well if they are that good why did they not fit one to their flagship at the time, the 3.0 GTV?

I'm sure the 'flagship' was the 166 3.2 Super, or before that the 164 3.0 Cloverleaf...

My FIAT Stilo had an undertray. My 156 doesn't. Neither did my 166. 'nuff said

alexGS is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cover , needed , underengine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome