Where do i stand? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-12-09 Thread Starter
Status: -
AO Member
Join Date: Jul 2007
Location: Bristol
Posts: 135

Member car:

Alfa 156 2.4 JTD

Where do i stand?

Hi after changing thermostat today and letting car run with bonnet up i have noticed a noise comming from the cam belt area. Its kind of a scraping noisefrom under the cover along side a whining noise. Definatly not good! I have not owned the car that long (147 2.0ts)but did check when i brought it that the main dealer service history is genuine. The belt was done by them approx 17000 miles ago. What should there response be when i ring them tommorow, Will i have to take it back there (100 miles away) or can i take it to any alfa dealer? If it breaks who is liable for repair?

Thanks Rich
tri_land is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Belt done 17K miles ago - but how long ago? - 36K miles OR 3 years, remember.

Did you buy it from the dealer? If so you may have a stronger case if the worst happens, but it won't be easy - their contract for the work done was with their then customer, not you.

I'd tread gently at first, try to get them to confirm again that the work was done (and whether it was a full belt kit fitted) and then explain your concerns and ask the service manager for his advice. If you have a nearby dealer could be worth getting their opinion before speaking to the dealer who did the work. At the end of the day your redress in law is probably only against whoever you bought it from (IMHO - I'm not a lawyer)

AROC Vice-Chairman and Lancashire Section Secretary

Alfa organ donor to the gentry......
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome