147 problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-12-09 Thread Starter
Status: -
AO Member
SDFbby's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Hertfordshire
Posts: 17
147 problem

Hi everyone,

I'm new here and I have a bit of a problem with my 2001 147. The front bumper seems to hit down really hard if i go over any bumps on the road at speeds which it shouldn't. A friend of mine said it was just the suspensions and that he could take the car up a little bit to stop this from happening? Does this sound right? The body of the car looks to be low as it is covering a bit of the rear tyres. Is this how it should look?

And also I need new rear brake pads. Does anyone know how much they would cost (with and without labor) and where the best place to get them from is? I live in Sydney, Australia.

Any help would be appreciated!
Thanks in advance!!
SDFbby is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Mar 2008
Location: United Kingdom
County: Wrexham
Posts: 2,844
Images: 6

Member car:

GTA Shed wagon

Do you have any photos?
If that is your car in your avatar then it looks like it's been lowered, so the best thing to do is raise it so it doesn't catch on bumps.
rmaxeman is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome