My GT Goes Like Stink! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 02-12-09 Thread Starter
Status: -
AO Silver Member
Join Date: Feb 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 1,519
My GT Goes Like Stink!

Monday morning and the cold finally killed the battery in my GT.

I disconnect and remove the battery. Get in the Golf. Off to the motorsavers to buy a new battery. Get home. Refit and reconnect. Go out for a test drive. Wow! My car goes like stink!

It was quick before, but the acceleration has smoothed out (no massive turbo boost at 2500rpm) and it's quicker than it was, the rev counter spins to the red line really really quickly.

I'm guessing the ECU reset itself after being disconnected for about an hour.

Good stuff!
twincamms is offline  
Sponsored Links
Status: - Update
Posts: n/a
Sure it isn't just the cold weather? Increased air density is a wonderful thing and very noticeable in my JTD!!!
Status: El finto :(
AO Member
KendalBeefcake's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: Kent
Posts: 886
Images: 4

Member car:

159 SW Ti

Hi, was considering giving this a go just for a laugh (I'm on leave and have nothing to do apart from lurk on here and play MW2) Anyway, just for reference, how old is your GT and have you had it mapped/chipped?


KendalBeefcake is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome