engine light! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 02-12-09 Thread Starter
Status: -
jimv6's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Powys
Posts: 1

Member car:

alfa 156 2.5 v6

engine light!

my engine light has just come on, no difference in driving the car what could it be and what should i do please
jimv6 is offline  
Sponsored Links
Status: -
AO Member
deadmau5's Avatar
Join Date: Apr 2009
Location: I would rather not say
County: -
Posts: 167

Member car:

2001 GTV

if theres no difference in performance it probably won't be the MAF

Mine came on randomly last week, I lifted the bonnet, everything seemed fine, sprayed some WD40 around the engine bay on the cables/plugs and it went out.
deadmau5 is offline  
Status: - Update
Posts: n/a
i kept getting mine come on once, mine just turned out to be a misfire due to a failing spark plug.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome