rear f/s electric window problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 02-12-09 Thread Starter
Status: -
AO Member
Join Date: Nov 2009
Location: United Kingdom
County: Derbyshire
Posts: 24

Member car:

156 sportswagon

rear f/s electric window problems

again picked my alfa 156 sw up, the rear window wouldnt work, they have replaced whatever parts tey needed to replace, it worked, ive drove home and its not working again? is there a seperate fuse for each window? is there another fuse box other than the one under my steering wheel??

rafasheroes is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
What did they change? The rear e/w motors are known to fail, and the easiest way to fix it is to put a 2nd hand unit in.

SW ones are supposed to be different to saloon ones, but saloon ones have been known to fit!
iainfm is offline  
Status: -
AO Silver Member
PhilzAlfa's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Somerset
Posts: 3,126
According to my manual (for a 1998 156 saloon) there may be a fuse box in the top of the glovebox. Open the glovebox and look inside next to the catch. Fuse numbers 3 and 4 (20A) are for the rear windows.
PhilzAlfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electric , f or s , problems , rear , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome