ticking noise 156 2.0 Ltr - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 24-11-09 Thread Starter
Status: -
AO Member
Join Date: Nov 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 52
ticking noise 156 2.0 Ltr

well the cam belt was changed about 200 miles ago and the car also had a full 108 k service at the same time ( it has done 105K ).The wife has used the car every day to go to work a round trip of 20 milesfor the last week or so . However today i used the car and noticed a ticking sound coming from the engine ( like tapits ) or something like that .Anyway the sound gets worse and quiet loud at about 2,000 rpm upwards .......... you can even notice it at tick over .......... any ideas ?

Thanks in advance
happysnapper is offline  
Sponsored Links
Status: enjoying ma julie
AO Silver Member
belfast bob's Avatar
Join Date: Dec 2007
Location: United Kingdom
County: Antrim
Posts: 2,890
take a decent vid and post it and someone will know
belfast bob is offline  
Status: -
AO Member
Join Date: Oct 2009
Location: United Kingdom
County: Derbyshire
Posts: 13

Member car:

alfa romeo 156

hope its not big end like mine turned out to be
dalefletcher is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , ltr , noise , ticking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome