Alarm on drains battery - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-11-09 Thread Starter
Status: -
Join Date: Nov 2009
Location: United Kingdom
County: Gloucestershire
Posts: 3

Member car:


Alarm on drains battery

Has anyone any experience of the alarm on a 147 draining the battery when set? If I lock the car using the fob, a day or so later the alarm will go off and the car can not be unlocked with the fob. The key will open the car. Depending on how long I have not used the car for the battery can be completely flat. I have replaced the battery incase this was what was wrong. If it is only set for about a day the battery is fine, but the car won't unlock with the fob. nor will the boot button work. The only way to access the car is to use the key.

I have had the Alfa Workshop hook the car up to their computer, but they couldn't find any problem. and when they kept the car for a day they couldn't get it to replicate the problems i have with it.

If anyone has experienced something similar or can suggest what it might be that would be a great help, as at the moment the car can be locked, but not alarmed.
bacivino is offline  
Sponsored Links
Status: -
AO Member
austin35alfa147's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Somerset
Posts: 77
Hello, it may be coincidence that the alarm goes off, if you have access to a multimeter on the current range with the engine NOT RUNNING connect it between the negative terminal on the battery and the negative lead for the battery, next pull circuit fuses while a helper watches the meter and yells when the current reading on the meter falls off. When the load falls away ( there may be some small drain remaining, the clock for example) you have found the circuit that is at fault. A friends daughter had a similar problem with a corsa and it turned out to be the radio not turning off properly and taking half an amp, resulting in the same problem you mention overnight. Happy hunting, On my 53 plate 147 the battery can be removed without needing to reset any codes, but nevertheless i still have bought the codes from the main dealer just in case. Happy Hunting
austin35alfa147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alarm , battery , drains

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome