147 heated seats - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-11-09 Thread Starter
Status: -
Join Date: Oct 2009
Location: United Kingdom
County: Merseyside
Posts: 1

Member car:

Alfa 147

147 heated seats

Hi Guys I new to the forum and have a quiery I hope someone can help me with. I have recently bought myself a 147 Selespeed it has the winter pack fitted so has heated seats. The seats are working but are blowing the fuse. The recommended fuse is 15 amp I am thinking of trying a 20 amp fuse but I am a bit worried if this could cause any additional problems. Does anyone out there know (A) what the problem is and (B)How to rectify it safely.

Ta Wogsy::
wogsy is offline  
Sponsored Links
Status: - Update
Posts: n/a
Yea - swap your leather seats for my velour seats and et voila problem solved.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , heated , seats

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome