147 Frozen Hand Brake Problem ? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 15-11-09 Thread Starter
Status: -
AO Member
Join Date: Oct 2009
Location: United Kingdom
County: Greater Manchester
Posts: 25

Member car:

My wife crazy

147 Frozen Hand Brake Problem ?

On our previous Alfa ( 145 Cloverleaf ) we had endless trouble in winter time with the hand brake freezing in the on position. We've just bought a 147 and I'd like to know, did Alfa manage to rectify this problem. ? Or do I need to warn my wife not to pull the hand brake on fully during the winter months ? Thanks.
Passenger is offline  
Sponsored Links
Status: 251bhp/300Nm dynoed :)
AO Car Of The Year Winner 2015
Membro Premio
gotcha's Avatar
Join Date: Dec 2003
Location: Slovakia
County: Bratislavsky
Posts: 3,176
Its not Alfa 145 problem, but general for all cars as the handbrake system is almost universal and the cables or caliper or pads can freeze.

It is recommended for all cars not to use handbrake in icy/freezing conditions, just put the car in gear.
gotcha is offline  
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,073
You can help to reduce the problem by checking the rubber bellow on the end of the cables - possibly pulling them off the outer cable and spraying some WD40 or some such before putting the sleeves back on....
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , brake , frozen , hand , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome