ECU reset to clear MCSF - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 11-11-09 Thread Starter
Status: -
AO Member
Join Date: May 2007
Location: Belfast
Posts: 68
ECU reset to clear MCSF

Tried a suggested ECU reset following this warning - battery disconnected for 30mins and then reconnect, start and let her sit at idle for 10 mins.... you guessed the mcsf warning is still there.

Car still drives fine with it but worringly can cut all electrics randomly for a few seconds and then all returns to normal > not the best thing to happen on these dark nights. Also refused to start a couple of times with the mcsf symbol the only dash light to show up.... had like a pump noise switching on and off randomly even when ignition not even turned ? any ideas folks > does this suggest a dodgy fuel pump?

mechanic to check the air pipes / turbo pipes tomorrow and give the maf a clean to see if that helps.
red55s is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clear , ecu , mcsf , reset

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome