ABS sensor too long. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-11-09 Thread Starter
Status: -
AO Member
scot360's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: West Yorkshire
Posts: 384
Images: 10
ABS sensor too long.

i have tried to fit some new abs sensor`s to my 147 selespeed, but i have found it too be too long by about 2-3 mm as it touches the driveshaft.
can anyone help me out please?
it is definately the correct one for my car as i have actually bought both sets, one pair with the black plug and one pair with white/cream round plug, both have the sensor the same length.
the correct one for my car is the one with the round cream plug, but i have read of someone using the wrong one by cutting the plug off and joining it into the old one.

when it took the old sensor off i tried to measure it you cant actually because they are always jammed for good., it looked shorter than the new one and the end looked like it had rubbbed against the driveshaft as there was some plastic on the driveshaft also. why is this?

any help would very much appreciated.

i have seen lots of ABS threads on here, many about why the ABS sensors seem to fail when the driveshaft is removed then refitted, when really i can see no reason for this to happen as my sensors were not damaged or the cable damaged. none of the threads do not seem to have the resolution the problem.

do i need to reset the abs unit after fitting? or will the faults clear themselves?
scot360 is offline  
Sponsored Links
Status: Stopped
AO Member
Il Dottore's Avatar
Join Date: May 2005
Location: United Kingdom
County: Bedfordshire
Posts: 345
Can't help with the length of the sensor, but when I had trouble with the ABS on my twin spark I disconnected sensors and reconnected them many times, and every time I put the system back together the fault light cleared itself, no resetting needed.
Il Dottore is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

abs , long , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome