Airbag light reset on 147 HOW TO GUIDE? please? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
Join Date: Aug 2009
Location: United Kingdom
County: Essex
Posts: 48
I'm still having an issue where the amber airbag light will flash and beep at me when starting, then the light goes out. I've cleaned the connectors, reset via diag software (no errors). Any clues to stop this alarm every time I start the car?
chris432626 is offline  
Sponsored Links
Status: -
AO Member
Mighty-147's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Devon
Posts: 267
Whenever wiggling the wires and connectors to fix always disconnect the battery and leave the airbag detonator thingys to de-charge (capacitors)? I was advised.
Just in case the airbags go off.
I had my light reset for the MOT last month and it has come on again.
Last diag thing flagged up passenger pre-tensioner.
I thought it was the clip end - don't know much about seatbelt pre-tensioners - and there is a cable going to the driver's side clip - however the mech pointed out that being an Italian car the passenger side could be UK driver's side.

Hmmm.... more research needed...
Mighty-147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , airbag , guide , light , reset

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome