Abnormal engine rotation during warm up - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 31-10-09 Thread Starter
Status: -
Join Date: Oct 2009
Location: Brazil
County: Sao Paulo
Posts: 6

Member car:

156 2.0 TS 1999

Abnormal engine rotation during warm up


I have recently bought an 156 2.0 TS 1999 and this is my first post in alfaowner forum. Glad to be here!

This is the problem I have: When engine is cold, after startup it goes to about 1200 rpms, maybe 1 minute later, little by little revs reduce to 900 (guess this is normal operation). Few minutes later, temperature reaches 50 deg C and engine rotation drops to around 500 rpms, engine almost stalls, then rotation increases to around 800 and then drops, and it keeps doing this irregular operation for about 2 minutes and the problem just disapears when temperature increases just above 50 deg C. During the abnormal operation, engine does not respond to throttle.

Few days ago I made an experiment, after an engine cold start, I contolled throttle to maintain at around 1400 rpms. When temperature reached 50 deg C, revs dropped to 1100 rpms stayed there for 1-2 seconds and then returned to 1400, and kept doing that until temperature got hotter than 50 deg C.

Any ideas or suggestions? I thought of making an ECU/throttle reset.

Thanks in advance,

Rod100 is offline  
Sponsored Links
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
I would suspect the water temp sensor first on top of the thermostat.
Smaky is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

abnormal , engine , rotation , warm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome