147 - Car pulling to Left, squeaky suspension - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-10-09 Thread Starter
Status: -
AO Member
Join Date: May 2008
Location: United Kingdom
County: West Yorkshire
Posts: 144
147 - Car pulling to Left, squeaky suspension

Hi all,

I'm having a bit of a problem with my 147. Shortly after passing the MOT, my 147 has developed a slight pull towards the left, more noticeable when accellerating.

Now, this could be likely to the new tyre fitted to the front n/side as opposed to the offiside which needs replacement imminently. But, it doesnt explain the squeak coming from the front nearside, possibly the suspension as it was noticeable when going over bumps and travelling at low speed (avoiding camels at Knowlsey Safari Park this weekend).

My initial thoughts were;

1- wheel bearing?
2 -suspension bushes?
3- Suspension?
4 -I had a small animal living in the wheel arch....?

The car has done 90+k miles an is a 2001 TS Lusso.

Any advice you guys have would be gratefully received.

mickyl is offline  
Sponsored Links
Status: -
AO Member
BCSS147's Avatar
Join Date: Dec 2007
Location: surrey
Posts: 204
Hi, i also have this problem with the tyres its a case of changing two at a time that should solve the pulling,

the squeaky suspension i have also had and it turned out to be a wire under my n/s seat just tapping on the metal haha its always the small things to check 1st
BCSS147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , car , left , pulling , squeaky , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome