help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 24-10-09 Thread Starter
Status: -
AO Member
Join Date: Apr 2007
Posts: 12

Member car:

bmw 328


driving my selespeed the other day everything was fine then suddenly engine starts vibrating and dropping revs,quickly pulled over and the water was boiling hot and orange in colour now engine sounds as if its on three cylinders and shakes, even worse with air con on any ideas
wellis36 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
Some coolants are designed to change colour in the presence of exhaust gasses to indicate a head gasket failure.
So if your coolant wasn't orange before, that may be the reason.

Obviously STOP running the engine until it is fixed...!
David C is offline  
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Yep, I'll second that. If you can get it to a garage they'll be able to confirm it with a compression test...or you can buy one quite cheaply.

If it's head gasket, it's a head off, skim and refit job. Good opportunity to do the timing belts as well

To DIY, you're looking at about £20 for the cambelt, £70 for a gasket set (less for just the head gasket if you leave the manifolds on), £35 for the skim (that's what I get 'em for anyway). Add on tensioners/idlers/variator/water pump if they're due/required.
iainfm is offline  
(Post Link) post #4 of 4 Old 24-10-09 Thread Starter
Status: -
AO Member
Join Date: Apr 2007
Posts: 12

Member car:

bmw 328

thanks for that advice will get it checked straight away
wellis36 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome