Climate control blowing hot air or ice cold only in a Facelift 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 23-10-09 Thread Starter
Status: -
AO Member
Join Date: Sep 2008
Location: Ireland
County: Donegal
Posts: 29
Climate control blowing hot air or ice cold only in a Facelift 156

Hi folks,
I have been lurking for nearly a year and read with interest a lot of posts relating to the title and my problem as detailed above, now I have decided to stick my head up and seek a fix.
OK I have a 52 plate 156 1.6 TS which has climate control, that blows ice cold air in the LO setting (both pax and driver's side) and once the heat is turned up, say to 17c it blows out HOT HOT HOT air. Its good for me, but Ms Pablissimette hates the cold and extreme heat, and therefore hates the car. I have suggested adding more layers or stripping off, but she is not too keen (especially to the latter ).
Whe I bought the car last year it had a damaged passenger mirror cover and missing lens. I replaced this from eBAY, but I am thinking now that the temp sensor in the housing may be damaged or not connected, is there any way to find out. Would this temperature sensor cause the failure of hot/cold mixing or am I barking up the wrong tree?
I also have a faulty thermostat I think in the engine, the car's temperature guage doesn;t show that it is heating up on a clear road, but it will soar in traffic to sometimes the point the red line ignites, a rev of the engine brings this down though. [Should I post this in a different post?]

This is a fantastic forum BTW, I used to have a BMW and used BMWLand a lot, and learnt a lot from that site. I hope to do the same here and try and contribute as much as possible


pablissimo is offline  
Sponsored Links
Status: -
AO Gold Member
Join Date: Aug 2007
Posts: 7,040
The temp sensor probably does need replacing, but either way you'll need to take it to an Alfa dealer to get it checked out. I say this because either way you'll need your climate control ECU reprogrammed, and I belive only the dealers can do this!

Hope you get it sorted ok!
Spider95 is offline  
Status: AROC 916 Registrar
AO Gold Member
Mitch916's Avatar
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,803
Images: 8
I had exactly this fault. Climate ECU reset at main dealer, half an hour labour, 50.
Mitch916 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , air , blowing , climate , cold , control , facelift , hot , ice

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome