JTS Water Pump Failure... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
JTS Water Pump Failure...

Hello again,

as some of you may know i've been sorting out my car the last few weeks...
got it back from the menders today. my specialist, a guy, in Norwich did a fantastic job of getting my car sorted for me. new belts, waterpump, im now running selenia racing oil, new plugs, filters, and every single belt pulley was changed... variator tensioners etc...Runs like a Dream!!!

however. he showed me my waterpump and it was basically toast a few more miles would have killed it he reckons. looking at it, it would seem the bearing inside had exploded taking out the rest of the pump mechanism. and it was rusty as hell. could have been when the garage i got it from JETWASHED!!!! my engine bay.:bash:

moral of the story even if you have a JTS or a TS dont neglect your lovely water pump and dont jet wash an engine either.:bite:


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

failure , jts , pump , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome