Urgent help needed please! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-10-09 Thread Starter
Status: -
AO Member
liam156's Avatar
Join Date: Feb 2008
Location: Ireland
County: Dublin
Posts: 634
Images: 1
Urgent help needed please!

Hey all,

Quick question, I have my nct(mot) tomorrow and my rear brake light isn't working. I replaced the bulb so it's not that. But when I give the rear quarter a bang with my hands the brakelight often returns to working order until I hit a bump or pothole! Anyone any idea what is causing this? Possibly earthing? Any help appreciated ! thanks
liam156 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Connectors and earth points would be first place to check.

Earth points are behind the trim carpet below each light unit.

Can also be a poor contact inside the light unit, ie the bit the tip of the bulb touches.

Or could just be that your replacement bulb is faulty.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

needed , urgent

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome